ConfigMgr Prerequisites Tool – Version 1.4.0 has been released


It’s almost been a year since I’ve updated my prerequisites installation tool for ConfigMgr 2012 R2. With this new version being released, I’ve chosen to rename it to simply ConfigMgr Prerequisites Tool. The goal for version 1.4.0 has been to fix some of the reported bugs and add additional features. No new requirements of platform or operating support has been added, only new feature, bug fixes and

Release notes

In this new release, the following features and fixes are included:

  • Support for installation prerequisites for a State Migration Point
  • Override the validation checks by simply clicking a check box, although if the checks are overridden, you could see some unwanted errors (please report those so that I can try to catch them with a try/catch statement)
  • The tool is now catching the error many users have reported when launching in a sub-domain where the elevation check would fail. In those cases, just override the validation checks if you’re certain that you’ve launched the tool elevated
  • Add a Primary Site server computer account to the local Administrators group of the system where the script is executed
  • Create a NO_SMS_ON_DRIVE.SMS file on a specific volume
  • Updated Windows features selection range for Management Point and Distribution Point site system roles, to not cause failure when installing either role with HTTPS
  • General page has been updated with a new validation results view, now featuring pictures embedded in the code instead of marking the text green or red depending on the result
  • Some small code fixes and PowerShell best practices have been implemented, all just for the easy of reading the script (there’s more work to be done here though)

Download the ConfigMgr Prerequisites Tool

As with previous realeses, you can download the tool from the TechNet Gallery.

I hope you enjoy this new version, and please report any issues that you may have with it.

1 Comment

  1. DwightB


    Running into the below issue when running the prerequisite tool for pre-upgrade for SCCM. I am running the PS script as a domain admin, sccm admin, and the ps console as admin.

    WARNING: An error occured when attempting to query for elevation, possible due to issues contacting the domain or the tool is launched in a sub-domain. If used in a sub-domain, check the override checkbox to enable this tool

    Please advise.


Leave a Comment

Your email address will not be published. Required fields are marked *